Устанавливаем cherrytree в Debian 10

Думаю многим известна утилита cherrytree. Но по каким то не известным обычным пользователям причинам, она отсутствует в стандартных репозиториях Debian. Установка с сайта производителя так же не принесет результатов. Так как при установке deb пакета скаченного с сайта, утилита скажет что необходимы зависимости. Именно этих зависимостей так же нет в репозиториях. Можно конечно их поискать на сайте pkgs. Но можно cherrytree пойти и иным путем, и установить ее из репозиториев Unstable. При этом лично у меня каких либо проблем после установки не возникло. Про репозитории Testing и Unstable мы разбирали в этой статье. Вкратце опишу нужные нам действия, для установки нужно подключить рпозиторий Unstable. Для этого идем в консоль и вводим команду:

sudo nano /etc/apt/sources.list

После чего вписываем туда сам репозиторий:

deb http://ftp.ru.debian.org/debian/ unstable main non-free contrib
deb-src http://ftp.ru.debian.org/debian/ unstable main non-free contrib

Теперь сохраняем файл (ctrl + o) и выходим (ctrl + x).

Теперь обновляем списки репозиториев командой:

sudo apt update

Но не в коем случае не обновляем саму систему. То есть не в коем случае не вводим команду upgrade (sudo apt upgrade). Теперь можно установить cherrytree командой:

sudo apt install cherrytree

После установки настоятельно рекомендую комментировать данный репозиторий. И еще раз повторюсь, не обновляйте из него систему, а иначе у вас в системе могут появиться баги.

9 комментариев к «Устанавливаем cherrytree в Debian 10»

    1. На этом же сайте есть инструкция как установить репозитории от Mx Linux и antix, вот из них прекрасно все ставится, и не только chery tree а также много всяко другого я остался очень доволен, в этой связке LMDE заиграл весьма заманчивыми красками! Такое же проделал с Debian ! Работает все на ура, вот ссылка на инструкцию https://cyber-x.ru/%D0%BF%D0%BE%D0%B4%D0%BA%D0%BB%D1%8E%D1%87%D0%B0%D0%B5%D0%BC-%D1%80%D0%B5%D0%BF%D0%BE%D0%B7%D0%B8%D1%82%D0%BE%D1%80%D0%B8%D0%B9-mx-linux-%D0%BA-debian-10/

  1. В Linux Mint 20 Cinnamon тоже не работает – ругается на зависимость пакетов Pyton, удаленных из Ubuntu 20. На нерусских сайтах тоже пишут об этой проблеме. Ставиться только вроде-бы Flatpac пакет объемом около 700 мб – нафик-нафик такой объем.

    1. Пробовал установить ее и в openSUSE – там не ругается, а просто не запускается. Тоже нет каких-то зависимостей. Какая-то эпоха поломок наступила после обновлений – похоже и тут карановирус на мозги разработчиков подействовал. Да и в SUSE conky-manager устанавливается, но ни одни коньки не запускаются. В Ubuntu/Mint 20 ничего не сломали в этой программе? Спасибо за ответы.

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *